Vulnerability · Published Aug 18, 2026 · Assigned by GitHub_M

CVE-2026-68939Pyenv: Glob/wildcard metacharacters bypass is_version_safe(), causing silent version/interpreter substitution via unquoted expansion (CVE-2022-35861 residual)

Low 2.0

In plain English

A low-severity OS command injection in pyenv from pyenv. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities).

Severity (CVSS 4.0)2.0Low
Exploit odds (30 days)0.2%top 93.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Pyenv provides simple Python version management. Prior to 2.8.0, is_version_safe() in libexec/pyenv-version-file-read accepts shell glob metacharacters in .python-version values, and unquoted PYENV_VERSION expansion in libexec/pyenv-version-name, libexec/pyenv-which, libexec/pyenv-prefix, libexec/pyenv-local, libexec/pyenv-global, libexec/pyenv-version, and libexec/pyenv-versions pathname-expands the value against the current directory, allowing a matching attacker-controlled file to silently select a different installed interpreter or version. This issue is fixed in version 2.8.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13pyenvno fix listedDEBIAN-CVE-2026-68939
Debian:14pyenvno fix listedDEBIAN-CVE-2026-68939
Ubuntu:26.04:LTSpyenvno fix listedUBUNTU-CVE-2026-68939
Ubuntu:26.10pyenvno fix listedUBUNTU-CVE-2026-68939

Affected products (as reported)

VendorProductVersions
pyenv pyenv < 2.8.0

Weakness: CWE-78, CWE-88, CWE-155 · Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

References