Vulnerability · Published Aug 25, 2026 · Assigned by apache

CVE-2026-68569Apache Tomcat: Principal lookup can fail open in some cases

High 8.1

In plain English

A high-severity improper authentication in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.5%top 59.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Authentication vulnerability in Apache Tomcat meant that in some circumstances (e.g. CLIENT-CERT, SPNEGO) that a user would be authenticated even if the user did not exist in the DataSourceRealm. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-admin-webapps1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-admin-webapps1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-docs-webapp1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-docs-webapp1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-el-3.0-api1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-el-3.0-api1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-lib1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-lib1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.121-1.el9_8ALSA-2026:93469
AlmaLinux:8tomcat-webapps1:9.0.121-1.el8_10ALSA-2026:92869
AlmaLinux:9tomcat-webapps1:9.0.121-1.el9_8ALSA-2026:93469
Debian:12tomcat10no fix listedDEBIAN-CVE-2026-68569
Debian:13tomcat10no fix listedDEBIAN-CVE-2026-68569
Debian:14tomcat1010.1.60-1DEBIAN-CVE-2026-68569
Debian:13tomcat11no fix listedDEBIAN-CVE-2026-68569
Debian:14tomcat11no fix listedDEBIAN-CVE-2026-68569
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-68569
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-68569
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-68569
Rocky Linux:8tomcat1:9.0.121-1.el8_10RLSA-2026:92869
Rocky Linux:9tomcat1:9.0.121-1.el9_8RLSA-2026:93469
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-68569
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-68569
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2026-68569
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-68569
Ubuntu:26.10tomcat11no fix listedUBUNTU-CVE-2026-68569
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-68569
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-68569
Ubuntu:26.10tomcat9no fix listedUBUNTU-CVE-2026-68569

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.2410.1.0-M1 – through 10.1.579.0.0.M1 – through 9.0.1208.5.0 – through 8.5.1007.0.0 – through 7.0.109

Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References