Vulnerability · Published Aug 17, 2026 · Assigned by GitHub_M

CVE-2026-68520Glances: as_dict_secure() Value-Level Bypass Leaks Credentials in URL Values via /api/4/config

Medium 5.3

In plain English

A medium-severity information exposure in glances from nicolargo. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.4%top 65.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.6, as_dict_secure() in glances/config.py checks only option names and exposes public_username and credentials embedded in public_api values through unauthenticated GET /api/4/config and GET /api/4/config/ip requests. This issue is fixed in 4.5.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12glancesno fix listedDEBIAN-CVE-2026-68520
Debian:13glancesno fix listedDEBIAN-CVE-2026-68520
Debian:14glances4.5.6+dfsg-1DEBIAN-CVE-2026-68520
PyPIglances4.5.6PYSEC-2026-3664
PyPIglances4.5.6GHSA-4h34-v6r8-mmjc
Ubuntu:22.04:LTSglancesno fix listedUBUNTU-CVE-2026-68520
Ubuntu:24.04:LTSglancesno fix listedUBUNTU-CVE-2026-68520
Ubuntu:26.04:LTSglancesno fix listedUBUNTU-CVE-2026-68520

Affected products (as reported)

VendorProductVersions
nicolargo glances < 4.5.6

Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References