Vulnerability · Published Oct 14, 2026 · Assigned by GitHub_M

CVE-2026-67414RabbitMQ AMQP 1.0 parser: amplification memory-exhaustion DoS via zero-width array aggregation

Medium 6.0

In plain English

A medium-severity uncontrolled resource consumption in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.0Medium
Exploit odds (30 days)0.6%top 49.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.24, 4.1.15, 4.2.10, and 4.3.4, deps/amqp10_common/src/amqp10_binary_parser.erl materializes each element of AMQP 1.0 arrays whose shared constructor has zero width, while limiting only the number of elements in each array and not the aggregate arrays in a frame. After completing SASL authentication, a low-privilege client can send an ordinary frame containing many individually permitted arrays, causing a small frame to expand into a very large reader-process heap before later frame validation or authorization. Because deps/rabbit/src/rabbit_amqp_reader.erl clears the pre-authentication max_heap_size guard after login, repeated or concurrent frames can trigger the node-wide memory alarm, block publishers, or exhaust broker memory. This issue is fixed in versions 4.0.24, 4.1.15, 4.2.10, and 4.3.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67414
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67414
Debian:14rabbitmq-server4.3.6-1DEBIAN-CVE-2026-67414
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67414
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67414
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67414
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-67414

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.0.0, < 4.0.24>= 4.1.0, < 4.1.15>= 4.2.0, < 4.2.10>= 4.3.0, < 4.3.4

Weakness: CWE-400, CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References