Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M

CVE-2026-67409RabbitMQ: JWKS Fetch Ignores HTTP Response Status Code - Signing Key Destruction Causes Authentication DoS

High 8.2

In plain English

A high-severity security flaw in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.4%top 63.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 4.3.3, 4.2.9, 4.1.14, 4.0.23, and 3.13.18, JWKS Fetch Ignores HTTP Response Status Code - Signing Key Destruction Causes Authentication DoS (CWE-252). the JWKS key fetching mechanism in uaajwt.erl does not validate the HTTP response status code when downloading signing keys from the OAuth2 provider's JWKS endpoint. Non-200 responses (including 4xx and 5xx errors) are processed identically to successful responses. When the JWKS endpoint returns an error response with a valid-JSON body that lacks a keys field, all previously cached signing keys are destroyed, causing a persistent authentication denial of Files: deps/rabbitmqauthbackendoauth2/src/uaajwt.erl, lines 50-63 deps/rabbitmqauthbackendoauth2/src/uaajwks.erl, lines 5-7 deps/rabbitmqauthbackendoauth2/src/rabbitoauth2provider.erl, lines 98-107 Bug 1: HTTP status code ignored (uaajwt.erl:50-63): The Erlang httpc module returns {ok, {{HttpVersion, StatusCode, ReasonPhrase}, Headers, Body}}. The pattern {ok, {, , JwksBody}} matches ANY successful HTTP transaction Persistent authentication DoS: Once keys are destroyed, ALL OAuth2/JWT authentication fails for all users until a new successful JWKS refresh occurs Amplification: A single attacker can deny access to all legitimate OAuth2 users across the entire RabbitMQ. This issue is fixed in versions 4.3.3, 4.2.9, 4.1.14, 4.0.23, and 3.13.18.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67409
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67409
Debian:14rabbitmq-server4.3.6-1DEBIAN-CVE-2026-67409
Ubuntu:22.04:LTSrabbitmq-server3.9.27-0ubuntu0.6UBUNTU-CVE-2026-67409
Ubuntu:22.04:LTSrabbitmq-server3.9.27-0ubuntu0.6USN-8933-1
Ubuntu:24.04:LTSrabbitmq-server3.12.1-1ubuntu1.7USN-8933-1
Ubuntu:24.04:LTSrabbitmq-server3.12.1-1ubuntu1.7UBUNTU-CVE-2026-67409
Ubuntu:26.04:LTSrabbitmq-server4.0.5-10ubuntu5.2USN-8933-1
Ubuntu:26.04:LTSrabbitmq-server4.0.5-10ubuntu5.2UBUNTU-CVE-2026-67409
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-67409

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.3.0, < 4.3.3>= 4.2.0, < 4.2.9>= 4.1.0, < 4.1.14>= 4.0.0, < 4.0.23>= 3.13.0, < 3.13.18

Weakness: CWE-252 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References