Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M

CVE-2026-67241RabbitMQ: AMQP 1.0 management exchange.declare skips alternate-exchange permission check

Medium 4.8

In plain English

A medium-severity missing authorization in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)4.8Medium
Exploit odds (30 days)0.4%top 63.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.9 and 4.3.3, AMQP 1.0 management exchange.declare skips alternate-exchange permission check. pUT /exchanges/:name (lines 192-240) checks only configure on the declared exchange and passes XArgs straight to rabbitexchange:declare/7. It omits the checkreadpermitted(X) + checkwritepermitted(AE) that rabbitchannel.erl:2540-2548 enforces for the alternate-exchange argument on the AMQP 0-9-1 path. The same file already implements the analogous DLX check for queues (lines 708-719), confirming this is a missing-check bug rather than intentional A user with only configure on exchange X can route X's unroutable messages into an alternate exchange they have no write permission AMQP 1.0 enabled (default in RabbitMQ 4.x) Attacker has configure on at least one exchange but lacks write on the target. This issue is fixed in versions 4.2.9 and 4.3.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14rabbitmq-server4.3.6-1DEBIAN-CVE-2026-67241
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67241
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67241
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67241
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-67241

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.9>= 4.3.0, < 4.3.3

Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:H/SA:N

References