Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M

CVE-2026-67237RabbitMQ: Reflected XSS via the OAuth bootstrap JS endpoint

High 7.5

In plain English

A high-severity cross-site scripting in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.5High
Exploit odds (30 days)0.5%top 60.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.8 and 4.3.2, set_token_auth/2 inserted a bearer token from the Authorization header or access_token cookie into OAuth bootstrap JavaScript without escaping, allowing attacker-controlled token content to execute JavaScript in the management UI origin. The endpoint is exposed before authentication only when management.oauth_enabled is true, and exploitation through the cookie path additionally requires the attacker to plant an access_token cookie on the management host. This issue is fixed in versions 4.2.8 and 4.3.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14rabbitmq-server4.3.2-1DEBIAN-CVE-2026-67237
Ubuntu:22.04:LTSrabbitmq-server3.9.27-0ubuntu0.6USN-8933-1
Ubuntu:22.04:LTSrabbitmq-server3.9.27-0ubuntu0.6UBUNTU-CVE-2026-67237
Ubuntu:24.04:LTSrabbitmq-server3.12.1-1ubuntu1.7UBUNTU-CVE-2026-67237
Ubuntu:24.04:LTSrabbitmq-server3.12.1-1ubuntu1.7USN-8933-1
Ubuntu:26.04:LTSrabbitmq-server4.0.5-10ubuntu5.2USN-8933-1
Ubuntu:26.04:LTSrabbitmq-server4.0.5-10ubuntu5.2UBUNTU-CVE-2026-67237

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.8>= 4.3.0, < 4.3.2

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References