Vulnerability · Published Sep 24, 2026 · Assigned by GitHub_M

CVE-2026-67233RabbitMQ: Monitoring-tag user can DELETE shovels

Medium 6.0

In plain English

A medium-severity missing authorization in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.0Medium
Exploit odds (30 days)0.3%top 77.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.1, The shovel management resource's is_authorized/2 delegates to rabbit_mgmt_util:is_authorized_monitor/2, which accepts the monitoring tag. But allowed_methods includes DELETE, and delete_resource/2 deletes / restarts shovel runtime parameters with no additional role check. A monitoring user , intended to have read-only visibility , can therefore delete or restart any shovel in any vhost they can see. A read-only monitoring user can delete or restart any dynamic shovel , a state-changing operation that the equivalent /api/parameters endpoint correctly restricts to policymaker. Preconditions include rabbitmq_shovel + rabbitmq_shovel_management plugins enabled Attacker has credentials with the monitoring tag. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67233
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67233
Debian:14rabbitmq-server4.3.2-1DEBIAN-CVE-2026-67233
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67233
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67233
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67233
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-67233

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 3.13.0, < 3.13.15>= 4.0.0, < 4.0.20>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6>= 4.3.0, < 4.3.1

Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

References