Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M
CVE-2026-67231RabbitMQ: Trust-store whitelist by Issuer+Serial only
Critical 9.1
In plain English
A critical-severity improper certificate validation in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, The trust-store plugin installs a verify_fun that overrides {bad_cert, unknown_ca} / {bad_cert, selfsigned_peer} when the presented cert "matches" a whitelisted one. The match key is extract_issuer_id/1 → public_key:pkix_issuer_id/2 → {IssuerName, SerialNumber} , both fields are taken verbatim from the presented certificate body and contain no public-key, SKI, fingerprint or signature material. is_whitelisted/1 is a pure ets:member lookup; the stored full DER is used only for list/0 display and is never compared against the presented cert. cacerts is [], so the whitelisted cert is never used as a trust anchor for path validation either. TLS client-authentication bypass: an attacker who knows the issuer DN + serial of any whitelisted certificate can connect with a forged self-signed cert. Preconditions include rabbitmq_trust_store plugin enabled and used as the TLS verify_fun Attacker knows or can guess the {Issuer, Serial} of at least one whitelisted cert (non-secret; exposed via CLI/logs/any cert copy). This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-67231 |
| Debian:13 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-67231 |
| Debian:14 | rabbitmq-server | 4.3.0-2 | DEBIAN-CVE-2026-67231 |
| Ubuntu:22.04:LTS | rabbitmq-server | 3.9.27-0ubuntu0.6 | UBUNTU-CVE-2026-67231 |
| Ubuntu:22.04:LTS | rabbitmq-server | 3.9.27-0ubuntu0.6 | USN-8933-1 |
| Ubuntu:24.04:LTS | rabbitmq-server | 3.12.1-1ubuntu1.7 | USN-8933-1 |
| Ubuntu:24.04:LTS | rabbitmq-server | 3.12.1-1ubuntu1.7 | UBUNTU-CVE-2026-67231 |
| Ubuntu:26.04:LTS | rabbitmq-server | 4.0.5-10ubuntu5.2 | USN-8933-1 |
| Ubuntu:26.04:LTS | rabbitmq-server | 4.0.5-10ubuntu5.2 | UBUNTU-CVE-2026-67231 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rabbitmq | rabbitmq-server | >= 3.13.0, < 3.13.15>= 4.0.0, < 4.0.20>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6 |
Weakness: CWE-295 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-cw8c-4m83-9c6w x_refsource_CONFIRM
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.0 x_refsource_MISC