Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M

CVE-2026-67229RabbitMQ: Admin-only atom exhaustion: atomize_keys on vhost metadata

Medium 6.9

In plain English

A medium-severity uncontrolled resource consumption in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.4%top 66.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, add_vhost/2 calls rabbit_data_coercion:atomize_keys/1 (the unsafe variant using binary_to_atom) on the vhost metadata map. The 20 MB management body limit fits ~1M+ short keys. Admin-only. An administrator importing a crafted definitions file can crash the node in a single request: a vhosts entry with ~1M unique metadata keys exhausts the atom table during import. Preconditions include administrator tag. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67229
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67229
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-67229
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67229
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67229
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67229

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 3.13.0, < 3.13.15>= 4.0.0, < 4.0.20>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6

Weakness: CWE-400 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References