Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M
CVE-2026-67228RabbitMQ: Atom exhaustion: to_atom on runtime-parameter component
Medium 6.9
In plain English
A medium-severity uncontrolled resource consumption in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, The runtime-parameters lookup path coerces the URL :component segment to an atom with rabbit_data_coercion:to_atom/1 in lookup_component/1 (deps/rabbit/src/rabbit_runtime_parameters.erl), creating a new atom for any previously unseen value. A safe helper, rabbit_registry:binary_to_type/1, which uses binary_to_existing_atom with a catch, already exists but is not used at this call site. lookup_component/1 calls rabbit_data_coercion:to_atom(Component) on the :component segment of the request URL, converting an attacker-supplied string into a new atom. Because the Erlang atom table is bounded and atoms are never garbage collected, an authorized policymaker issuing roughly one million requests with distinct component values can exhaust the atom table and crash the node, resulting in a denial of service. Preconditions include Exploitation requires policymaker privileges and roughly one million requests.. This issue is fixed in versions 4.2.7 and 4.3.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | rabbitmq-server | 4.3.2-1 | DEBIAN-CVE-2026-67228 |
| Ubuntu:22.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67228 |
| Ubuntu:24.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67228 |
| Ubuntu:26.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67228 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rabbitmq | rabbitmq-server | >= 4.2.0, < 4.2.7>= 4.3.0, < 4.3.1 |
Weakness: CWE-400 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-73qp-fwh4-2q5g x_refsource_CONFIRM
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.7 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.1 x_refsource_MISC