Vulnerability · Published Sep 25, 2026 · Assigned by GitHub_M
CVE-2026-67223RabbitMQ: LDAP DN injection via unescaped substitution
Medium 6.3
In plain English
A medium-severity security flaw in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
RabbitMQ is a messaging and streaming broker. The advisory establishes affected 3.13, 4.0, 4.1, 4.2, and 4.3 maintenance lines but contains conflicting first-fixed versions for the 3.13, 4.0, and 4.1 lines. fill/2 substitutes ${username} into user_dn_pattern without RFC 4514 DN escaping, allowing a crafted username to alter the LDAP bind DN and potentially select a different directory entry. Exploitation requires rabbitmq_auth_backend_ldap with a user_dn_pattern containing ${username}, a directory layout in which the injected suffix resolves usefully, and a password valid for the resulting DN. The advisory body identifies 3.13.15, 4.0.20, 4.1.11, 4.2.9, and 4.3.3 as fixed, while structured metadata identifies 3.13.18, 4.0.23, 4.1.14, 4.2.9, and 4.3.3. No fixed-version assertion is certifiable until a curator resolves this conflict.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-67223 |
| Debian:13 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-67223 |
| Debian:14 | rabbitmq-server | 4.3.6-1 | DEBIAN-CVE-2026-67223 |
| Ubuntu:22.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67223 |
| Ubuntu:24.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67223 |
| Ubuntu:26.04:LTS | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67223 |
| Ubuntu:26.10 | rabbitmq-server | no fix listed | UBUNTU-CVE-2026-67223 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rabbitmq | rabbitmq-server | >= 3.13.0, < 3.13.18>= 4.0.0, < 4.0.23>= 4.1.0, < 4.1.14>= 4.2.0, < 4.2.9>= 4.3.0, < 4.3.3 |
Weakness: CWE-90 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-9x7r-g78c-5835 x_refsource_CONFIRM
- https://github.com/rabbitmq/rabbitmq-server/commit/ad3ca47accd313a4a0dbcbbe17bf60fc8f4b2614 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/commit/b54056e59b7fd3a2d7f07dfaba95f026e138eee8 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.9 x_refsource_MISC
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.3 x_refsource_MISC