Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M

CVE-2026-67219RabbitMQ: Consistent-hash exchange unbounded weight

Medium 6.0

In plain English

A medium-severity resource allocation without limits in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.0Medium
Exploit odds (30 days)0.3%top 76.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, add_binding/3 parses the routing key as an integer weight N and computes ring positions with lists:seq(NextN0, NextN0 + N - 1). validate_binding/2 only checks N >= 1 , no upper bound. The resulting list is stored in the exchange's Khepri record, replicated cluster-wide, and reloaded on restart. A user with write permission on a consistent-hash exchange and read on a queue can create a binding whose routing key (the hash-ring weight) is an arbitrarily large integer. The broker allocates a list of that many integers via lists:seq/2 and persists it to Khepri across all cluster nodes , a single binding with weight 100000000 allocates ~800 MB on every node and survives restarts. Preconditions include rabbitmq_consistent_hash_exchange plugin enabled write permission on a consistent-hash exchange + read on a queue (standard binding perms). This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-67219
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-67219
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-67219
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67219
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67219
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-67219

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 3.13.0, < 3.13.15>= 4.0.0, < 4.0.20>= 4.1.0, < 4.1.11>= 4.2.0, < 4.2.6

Weakness: CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References