Vulnerability · Published Sep 23, 2026 · Assigned by GitHub_M
CVE-2026-66070RabbitMQ: CORS * reflects Origin with Allow-Credentials
High 7.6
In plain English
A high-severity security flaw in rabbitmq-server from rabbitmq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.17, 4.0.22, 4.1.13, and 4.2.6, match_origin/1 returned the bare reflected Origin and allowed credentials even when the wildcard "" was configured, so the response echoed the attacker's origin together with Access-Control-Allow-Credentials. The affected code is rabbit_mgmt_cors.erl. When the management plugin is configured with a wildcard CORS origin (cors_allow_origins = ""), the handler reflects the request Origin back in Access-Control-Allow-Origin and also sends Access-Control-Allow-Credentials: true. A malicious web page that a signed-in administrator visits can then use that administrator's cached HTTP Basic credentials to issue authenticated, state-changing requests to the management API. Preconditions include The management plugin is configured with the wildcard cors_allow_origins = "*", which is an explicit operator misconfiguration A target administrator has a cached HTTP Basic-auth session in the browser. This issue is fixed in versions 3.13.17, 4.0.22, 4.1.13, and 4.2.6.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-66070 |
| Debian:13 | rabbitmq-server | no fix listed | DEBIAN-CVE-2026-66070 |
| Debian:14 | rabbitmq-server | 4.3.0-2 | DEBIAN-CVE-2026-66070 |
| Ubuntu:22.04:LTS | rabbitmq-server | 3.9.27-0ubuntu0.6 | UBUNTU-CVE-2026-66070 |
| Ubuntu:22.04:LTS | rabbitmq-server | 3.9.27-0ubuntu0.6 | USN-8933-1 |
| Ubuntu:24.04:LTS | rabbitmq-server | 3.12.1-1ubuntu1.7 | USN-8933-1 |
| Ubuntu:24.04:LTS | rabbitmq-server | 3.12.1-1ubuntu1.7 | UBUNTU-CVE-2026-66070 |
| Ubuntu:26.04:LTS | rabbitmq-server | 4.0.5-10ubuntu5.2 | USN-8933-1 |
| Ubuntu:26.04:LTS | rabbitmq-server | 4.0.5-10ubuntu5.2 | UBUNTU-CVE-2026-66070 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rabbitmq | rabbitmq-server | >= 3.13.0, < 3.13.17>= 4.0.0, < 4.0.22>= 4.1.0, < 4.1.13>= 4.2.0, < 4.2.6 |
Weakness: CWE-942 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-p3hp-v9wh-ghm7 x_refsource_CONFIRM
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6 x_refsource_MISC