Vulnerability · Published Jul 30, 2026 · Assigned by GitHub_M

CVE-2026-66066Action Pack: Possible arbitrary file read and remote code execution in Active Storage variant processing

Critical 9.5

In plain English

A critical-severity security flaw in rails from rails. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 30.1% (higher than 98% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.5Critical
Exploit odds (30 days)30.1%top 1.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling2Metasploit, Public PoC

Official description

Action Pack is a framework for handling and responding to web requests. In versions prior to 7.2.3.2, 8.0.5.1 and 8.1.3.1, Active Storage does not disable libvips operations marked unsafe for untrusted content, allowing a crafted upload to invoke such an operation. Consuming applications are affected when configured to use libvips and accept image uploads from untrusted users. An unauthenticated attacker may exploit this behavior to read arbitrary files accessible to the Rails process, including environment variables and application secrets. Exposure of credentials such as secret_key_base or external-service tokens may enable remote code execution or lateral movement. This issue has been fixed in versions 7.2.3.2, 8.0.5.1 and 8.1.3.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rails2:6.1.7.10+dfsg-1~deb12u3DEBIAN-CVE-2026-66066
Debian:13rails2:7.2.2.2+dfsg-2~deb13u2DEBIAN-CVE-2026-66066
Debian:14rails2:7.2.3.2+dfsg-1DEBIAN-CVE-2026-66066
RubyGemsactivestorage8.0.5.1GHSA-xr9x-r78c-5hrm
RubyGemsactivestorage7.2.3.2GHSA-xr9x-r78c-5hrm
RubyGemsactivestorage8.1.3.1GHSA-xr9x-r78c-5hrm
Ubuntu:24.04:LTSrailsno fix listedUBUNTU-CVE-2026-66066
Ubuntu:26.04:LTSrailsno fix listedUBUNTU-CVE-2026-66066
Ubuntu:26.10railsno fix listedUBUNTU-CVE-2026-66066

Affected products (as reported)

VendorProductVersions
rails rails < 7.2.3.2>= 8.0.0.beta1, < 8.0.5.1>= 8.1.0.beta1, < 8.1.3.1

Weakness: CWE-1188 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

References