Vulnerability · Published Aug 10, 2026 · Assigned by apache

CVE-2026-65948Apache Ranger: UnixAuth lacks brute-force protection

High 7.3

In plain English

A high-severity security flaw in Apache Ranger from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities).

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.6%top 50.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

UnixAuth lacks brute-force protection in Apache Ranger versions <= 2.8.0.  Note:  UnixAuth is NOT a recommended option for production deployments.  Users are recommended to upgrade to version 2.9.0, which fixes this issue.

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Ranger 0 – through 2.8.0

Weakness: CWE-307 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References