Vulnerability · Published Jul 22, 2026 · Assigned by VulnCheck
CVE-2026-65591n8n before 1.123.64 Sanitizer Bypass Remote Code Execution
High 8.9
In plain English
A high-severity expression language injection in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. An authenticated user with workflow create or modify permissions can craft a malicious expression to bypass the sanitizer and achieve host-level code execution as the n8n process. The legacy expression engine is the default in affected versions. Fixed in n8n 1.123.64, 2.29.8, and 2.30.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | n8n | 1.123.64 | GHSA-pm35-fqvh-cq5g |
| npm | n8n | 2.30.1 | GHSA-pm35-fqvh-cq5g |
| npm | n8n | 2.29.8 | GHSA-pm35-fqvh-cq5g |
Affected products (as reported)
Weakness: CWE-917 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:L
References
- GitHub Security Advisory (GHSA-pm35-fqvh-cq5g) vendor-advisory
- VulnCheck Advisory: n8n before 1.123.64 Sanitizer Bypass Remote Code Execution third-party-advisory