Vulnerability · Published Aug 6, 2026 · Assigned by GitHub_M
CVE-2026-64663Statamic: Unsafe method invocation via Antlers template resolution allows data destruction
Medium 6.5
In plain English
A medium-severity security flaw in cms from statamic. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.74.1 and 6.24.0, manipulating user-supplied input incorporated into Antlers templates could result in the loss of content and assets, on sites whose templates pass untrusted input into affected areas, and exploitation did not require authentication. This issue is fixed in versions 5.74.1 and 6.24.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | statamic/cms | 5.74.1 | GHSA-j2vp-f2pv-5rj4 |
| Packagist | statamic/cms | 6.24.0 | GHSA-j2vp-f2pv-5rj4 |
Affected products (as reported)
Weakness: CWE-470 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H
References
- https://github.com/statamic/cms/security/advisories/GHSA-j2vp-f2pv-5rj4 x_refsource_CONFIRM