Vulnerability · Published Aug 6, 2026 · Assigned by GitHub_M
CVE-2026-64655GitHub CLI: Attestation Verification Bypass via Unescaped Regex Metacharacters in SAN Matching
Low 2.1
In plain English
A low-severity security flaw in cli from cli. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
GitHub CLI (gh) is GitHub’s official command line tool. Prior to 2.97.0, gh attestation verify builds the certificate Subject Alternative Name matcher from the --signer-repo and --signer-workflow flag values without escaping regex metacharacters, so a user-supplied repository or workflow name is treated as a regular expression rather than a literal string. Because GitHub permits characters such as `.` in organization, repository, and workflow path names and `.` is a regex wildcard, an attacker can register a lookalike name (for example github/artifact.attestations-workflows) that satisfies a matcher intended for a different trusted signer (github/artifact-attestations-workflows), bypassing the intended Sigstore attestation verification. Exploitation requires the attacker to create a plausible lookalike repository and produce valid attestations from it, which could undermine supply chain verification for CI/CD pipelines or policy gates that pin trust to a specific signing workflow. This issue is fixed in version 2.97.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | gh | no fix listed | DEBIAN-CVE-2026-64655 |
| Debian:13 | gh | no fix listed | DEBIAN-CVE-2026-64655 |
| Go | github.com/cli/cli | no fix listed | GO-2026-6767 |
| Go | github.com/cli/cli/v2 | 2.97.0 | GO-2026-6767 |
| Go | github.com/cli/cli/v2 | 2.97.0 | GHSA-mm27-mwq9-fr5g |
| Ubuntu:22.04:LTS | gh | no fix listed | UBUNTU-CVE-2026-64655 |
| Ubuntu:26.10 | gh | no fix listed | UBUNTU-CVE-2026-64655 |
Affected products (as reported)
Weakness: CWE-185 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N
References
- https://github.com/cli/cli/security/advisories/GHSA-mm27-mwq9-fr5g x_refsource_CONFIRM
- https://github.com/cli/cli/commit/55dbb4dc6b7edb10b48e3d7fc5bccd32318d1b55 x_refsource_MISC
- https://github.com/cli/cli/releases/tag/v2.97.0 x_refsource_MISC