Vulnerability · Published Jul 27, 2026 · Assigned by GitHub_M
CVE-2026-64642Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale
High 8.3
In plain English
A high-severity security flaw in next.js from vercel. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Next.js is a React framework for building full-stack web applications. In versions 16.0.0 through 16.2.10, crafted requests targeting Next.js applications using App Router built with Turbopack and a single entry in config.i18n.locales can bypass middleware/proxy based authentication. This issue has been fixed in version 16.2.11.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | next | 16.2.11 | GHSA-6gpp-xcg3-4w24 |
Affected products (as reported)
Weakness: CWE-285 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/vercel/next.js/security/advisories/GHSA-6gpp-xcg3-4w24 x_refsource_CONFIRM
- https://github.com/vercel/next.js/pull/96014 x_refsource_MISC
- https://github.com/vercel/next.js/commit/6bf4df14508ad6c0cd46af50c6051ee42f2d9151 x_refsource_MISC
- https://github.com/vercel/next.js/releases/tag/v16.2.11 x_refsource_MISC