Vulnerability · Published Apr 17, 2026 · Assigned by AMZN
CVE-2026-6437AWS EFS CSI Driver Mount Option Injection
Medium 6.5
In plain English
A medium-severity argument injection in AWS EFS CSI Driver from Amazon. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection. To remediate this issue, users should upgrade to version v3.0.1
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/kubernetes-sigs/aws-efs-csi-driver | 1.7.8-0.20260416142831-51806c22c575 | GHSA-mph4-q2vm-w2pw |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Amazon | AWS EFS CSI Driver | 0 – before 3.0.1 |
Weakness: CWE-88 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N