Vulnerability · Published Sep 29, 2026 · Assigned by GitHub_M

CVE-2026-63209Integer Overflow or Wraparound and Out-of-bounds Write in compress

High 7.5

In plain English

A high-severity integer overflow in compress from klauspost. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 52.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

compress provides various compression algorithms. Prior to version 1.18.7, a signed integer overflow vulnerability in s2.NewDict() allows an attacker to bypass repeat index validation by supplying a dictionary with a uvarint-encoded repeat value exceeding MaxInt64. When Dict.Encode() is subsequently called, the overflowed negative repeat value causes an out-of-bounds memory access via unsafe.Pointer arithmetic, crashing the process with SIGSEGV. This issue has been patched in version 1.18.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13golang-github-klauspost-compressno fix listedDEBIAN-CVE-2026-63209
Debian:14golang-github-klauspost-compress1.19.0+ds1-1DEBIAN-CVE-2026-63209
Gogithub.com/klauspost/compress1.18.7GHSA-259r-337f-4rfw
Gogithub.com/klauspost/compress1.18.7GO-2026-5841
Ubuntu:22.04:LTSgolang-github-klauspost-compressno fix listedUBUNTU-CVE-2026-63209
Ubuntu:24.04:LTSgolang-github-klauspost-compressno fix listedUBUNTU-CVE-2026-63209
Ubuntu:26.04:LTSgolang-github-klauspost-compressno fix listedUBUNTU-CVE-2026-63209
Ubuntu:26.10golang-github-klauspost-compressno fix listedUBUNTU-CVE-2026-63209

Affected products (as reported)

VendorProductVersions
klauspost compress < 1.18.7

Weakness: CWE-190, CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References