Vulnerability · Published Sep 21, 2026 · Assigned by GitHub_M

CVE-2026-62371KubeEdge: Command Injection in NodeUpgradeJob - RCE on edge nodes via v1alpha2 API

High 8.8

In plain English

A high-severity OS command injection in kubeedge from kubeedge. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.5%top 58.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

KubeEdge is an open source system for extending native containerized application orchestration capabilities to hosts at Edge. From 1.12.0 until 1.21.2, 1.22.2, and 1.23.1, the v1alpha2 NodeUpgradeJob handler in edge/pkg/taskmanager/actions/nodeupgradejob.go concatenates authenticated user-controlled spec.version and spec.image values into the keadm upgrade edge shell command. A user with permission to create or update NodeUpgradeJob resources can supply shell metacharacters in either field, causing arbitrary commands to execute on targeted edge nodes with the privileges of the upgrade process and compromising node confidentiality, integrity, and availability. This issue is fixed in versions 1.21.2, 1.22.2, and 1.23.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/kubeedge/kubeedge1.21.2GHSA-5jpj-293f-rhvj
Gogithub.com/kubeedge/kubeedge1.22.2GHSA-5jpj-293f-rhvj
Gogithub.com/kubeedge/kubeedge1.23.1GHSA-5jpj-293f-rhvj
Gogithub.com/kubeedge/kubeedge1.21.2, 1.22.2, 1.23.1GO-2026-6557

Affected products (as reported)

VendorProductVersions
kubeedge kubeedge >= 1.12.0, < 1.21.2>= 1.22.0, < 1.22.2>= 1.23.0, < 1.23.1

Weakness: CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References