Vulnerability · Published Oct 30, 2026 · Assigned by GitHub_M
CVE-2026-61846Crass: Deeply nested CSS blocks and functions can trigger a SystemStackError or excessive memory usage
Medium 6.3
In plain English
A medium-severity security flaw in crass from rgrove. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Crass is a Ruby CSS parser that's fully compliant with the CSS Syntax Level 3 specification. Prior to 1.0.7, Crass recursively parses `CSS simple blocks and functions` without a depth guard. An attacker-controlled CSS value containing deeply nested blocks or functions can recurse until Ruby raises `SystemStackError`: stack level too deep, or cause excessive memory usage. Version 1.0.7 adds a configurable depth limit with a conservative default. This issue is fixed in version 1.0.7.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | ruby-crass | no fix listed | DEBIAN-CVE-2026-61846 |
| Debian:13 | ruby-crass | no fix listed | DEBIAN-CVE-2026-61846 |
| Debian:14 | ruby-crass | 1.0.7-1 | DEBIAN-CVE-2026-61846 |
| RubyGems | crass | 1.0.7 | GHSA-6jxj-px6v-747w |
| Ubuntu:22.04:LTS | ruby-crass | no fix listed | UBUNTU-CVE-2026-61846 |
| Ubuntu:24.04:LTS | ruby-crass | no fix listed | UBUNTU-CVE-2026-61846 |
| Ubuntu:26.04:LTS | ruby-crass | no fix listed | UBUNTU-CVE-2026-61846 |
| Ubuntu:26.10 | ruby-crass | no fix listed | UBUNTU-CVE-2026-61846 |
Affected products (as reported)
Weakness: CWE-674 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L
References
- https://github.com/rgrove/crass/security/advisories/GHSA-6jxj-px6v-747w x_refsource_CONFIRM
- https://github.com/rgrove/crass/commit/cf68287356ec6e20d51cfc4a2d0c3912b7334e99 x_refsource_MISC
- https://github.com/rgrove/crass/releases/tag/v1.0.7 x_refsource_MISC