Vulnerability · Published Sep 15, 2026 · Assigned by GitHub_M

CVE-2026-61668DIRAC: Pilot code downloaded over unverified HTTPS connection

High 8.1

In plain English

A high-severity improper certificate validation in DIRAC from DIRACGrid. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.4%top 66.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

DIRAC is an interware, meaning a software framework for distributed computing. Prior to versions 8.0.79, 9.0.22, and 9.1.10, WorkloadManagementSystem/Utilities/PilotWrapper.py pilotWrapperScript uses ssl._create_unverified_context to download the second-stage pilot.tar archive without TLS certificate verification and downloads the reference checksum through the same unvalidated channel. An attacker able to redirect or intercept a grid site's network traffic through DNS or routing manipulation can substitute both the executable pilot code and its checksum, causing arbitrary code to run in the pilot context with access to pilot proxy credentials. The fixed implementation validates the server certificate through system trust and X509_CERT_DIR or the grid certificate directory. This issue is fixed in versions 8.0.79, 9.0.22, and 9.1.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIdirac8.0.79GHSA-vg99-gr89-qhw9
PyPIdirac9.0.22GHSA-vg99-gr89-qhw9
PyPIdirac9.1.10GHSA-vg99-gr89-qhw9
PyPIdirac8.0.79, 9.0.22, 9.1.10PYSEC-2026-3464

Affected products (as reported)

VendorProductVersions
DIRACGrid DIRAC >= 6.20.1, < 8.0.79>= 9.0.0a1, < 9.0.22>= 9.1.0, < 9.1.10

Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

References