Vulnerability · Published Aug 17, 2026 · Assigned by GitHub_M

CVE-2026-61666websocket-driver: Denial of service via malformed Host header

High 8.9

In plain English

A high-severity security flaw in websocket-driver-ruby from faye. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.9High
Exploit odds (30 days)0.4%top 61.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

websocket-driver is a WebSocket protocol handler with pluggable I/O. Prior to 0.8.2, WebSocket::Driver.server() passes a malformed Host header to URI.parse in lib/websocket/http/request.rb without catching URI::InvalidURIError, allowing a remote client to crash a TCP-backed WebSocket server when the application does not catch the error from parse(). This issue is fixed in version 0.8.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-websocket-driverno fix listedDEBIAN-CVE-2026-61666
Debian:13ruby-websocket-driverno fix listedDEBIAN-CVE-2026-61666
Debian:14ruby-websocket-driver0.8.2-1DEBIAN-CVE-2026-61666
RubyGemswebsocket-driver0.8.2GHSA-2x63-gw47-w4mm
Ubuntu:22.04:LTSruby-websocket-driverno fix listedUBUNTU-CVE-2026-61666
Ubuntu:24.04:LTSruby-websocket-driverno fix listedUBUNTU-CVE-2026-61666
Ubuntu:26.04:LTSruby-websocket-driverno fix listedUBUNTU-CVE-2026-61666
Ubuntu:26.10ruby-websocket-driverno fix listedUBUNTU-CVE-2026-61666

Affected products (as reported)

VendorProductVersions
faye websocket-driver-ruby < 0.8.2

Weakness: CWE-248 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H

References