Vulnerability · Published Sep 15, 2026 · Assigned by GitHub_M
CVE-2026-61544libp2p-quic: Remote panic via certificate expiry race during QUIC handshake
High 8.2
In plain English
A high-severity security flaw in rust-libp2p from libp2p. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities).
Official description
libp2p-rust is the official Rust language implementation of the libp2p networking stack. Prior to 0.13.1, libp2p-quic could panic during an inbound QUIC handshake when a remote peer presented a valid short-lived libp2p TLS certificate and delayed the final TLS 1.3 handshake fragment until after the certificate expired. In the Quinn post-handshake upgrade path, transports/quic/src/connection/connecting.rs called libp2p_tls::certificate::parse a second time in remote_peer_id and used expect on the result. The repeated wall-clock validity check could reject the now-expired certificate, causing the expect call to terminate any application exposing an affected libp2p-quic listener. This vulnerability is fixed in 0.13.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:26.04:LTS | rust-libp2p-identity | no fix listed | UBUNTU-CVE-2026-61544 |
| Ubuntu:26.10 | rust-libp2p-identity | no fix listed | UBUNTU-CVE-2026-61544 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| libp2p | rust-libp2p | < 0.13.1 |
Weakness: CWE-248 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/libp2p/rust-libp2p/security/advisories/GHSA-5hq8-qhww-jm7q x_refsource_CONFIRM
- https://github.com/libp2p/rust-libp2p/pull/6525 x_refsource_MISC
- https://github.com/libp2p/rust-libp2p/commit/212f3774af048e2cecfb2e6b1e08477685e52b22 x_refsource_MISC
- https://github.com/libp2p/rust-libp2p/commit/e8f35e12c2418b04df6e9cdf036005e8aee3c7a2 x_refsource_MISC