Vulnerability · Published Sep 16, 2026 · Assigned by apache
CVE-2026-59969Apache ZooKeeper: Improper validation of certificate with host mismatch in FIPS mode
High 7.5
In plain English
A high-severity security flaw in Apache ZooKeeper from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Apache ZooKeeper quorum TLS fails to enforce peer hostname verification in FIPS-mode deployments. When sslQuorum=true, zookeeper.fips-mode=true, ssl.quorum.hostnameVerification=true, and ssl.quorum.clientHostnameVerification=true are enabled, the Java SSLSocket quorum path accepts a CA-trusted peer certificate whose SAN does not match the connected host. A malicious or misissued peer certificate can therefore join quorum traffic, participate in leader election, and enter replication flows. Users are recommended to upgrade to version 3.8.7 or 3.9.6, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | zookeeper | no fix listed | DEBIAN-CVE-2026-59969 |
| Debian:13 | zookeeper | no fix listed | DEBIAN-CVE-2026-59969 |
| Debian:14 | zookeeper | 3.9.6-1 | DEBIAN-CVE-2026-59969 |
| Ubuntu:22.04:LTS | zookeeper | no fix listed | UBUNTU-CVE-2026-59969 |
| Ubuntu:24.04:LTS | zookeeper | no fix listed | UBUNTU-CVE-2026-59969 |
| Ubuntu:26.04:LTS | zookeeper | no fix listed | UBUNTU-CVE-2026-59969 |
| Ubuntu:26.10 | zookeeper | no fix listed | UBUNTU-CVE-2026-59969 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache ZooKeeper | 3.9.0 – through 3.9.53.8.0 – through 3.8.6 |
Weakness: CWE-297 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N