Vulnerability · Published Jul 29, 2026 · Assigned by GitHub_M
CVE-2026-59898Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation
Medium 6.3
In plain English
A medium-severity security flaw in netty from netty. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | netty | no fix listed | DEBIAN-CVE-2026-59898 |
| Debian:13 | netty | no fix listed | DEBIAN-CVE-2026-59898 |
| Debian:14 | netty | no fix listed | DEBIAN-CVE-2026-59898 |
| Maven | io.netty:netty-codec-http | 4.2.16.Final | GHSA-4mp9-239f-g9hg |
| Maven | io.netty:netty-codec-http | 4.1.136.Final | GHSA-4mp9-239f-g9hg |
| Ubuntu:26.10 | netty | no fix listed | UBUNTU-CVE-2026-59898 |
Affected products (as reported)
Weakness: CWE-444 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
References
- https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hg x_refsource_CONFIRM
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Final x_refsource_MISC
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Final x_refsource_MISC