Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M

CVE-2026-59882guzzlehttp/psr7: Host Confusion via Weak URI Host Validation

Medium 4.2

In plain English

A medium-severity security flaw in psr7 from guzzle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.2Medium
Exploit odds (30 days)0.3%top 75.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Prior to 2.12.3, Uri::assertValidHost() does not reject URI host components containing authority delimiters, embedded ports, or malformed IPv6 brackets, allowing Uri::getHost() to disagree with the URI authority used for security or routing decisions. This issue is fixed in version 2.12.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12php-guzzlehttp-psr7no fix listedDEBIAN-CVE-2026-59882
Debian:13php-guzzlehttp-psr7no fix listedDEBIAN-CVE-2026-59882
Debian:14php-guzzlehttp-psr72.12.3-1DEBIAN-CVE-2026-59882
Packagistguzzlehttp/psr72.12.3GHSA-c2w2-prh8-qm98
Ubuntu:24.04:LTSphp-guzzlehttp-psr7no fix listedUBUNTU-CVE-2026-59882
Ubuntu:25.10php-guzzlehttp-psr7no fix listedUBUNTU-CVE-2026-59882
Ubuntu:26.04:LTSphp-guzzlehttp-psr7no fix listedUBUNTU-CVE-2026-59882

Affected products (as reported)

VendorProductVersions
guzzle psr7 < 2.12.3

Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N

References