Vulnerability · Published Jul 14, 2026 · Assigned by apache
CVE-2026-59084Apache Tomcat: EncryptInterceptor requirements not clearly documented
Critical 9.1
In plain English
A critical-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Insufficient Technical Documentation vulnerability in Apache Tomcat since the requirements to securely configure the EncryptInterceptor were not clearly documented. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.23, from 10.1.0-M1 through 10.1.56, from 9.0.13 through 9.0.119, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.24, 10.1.57 or 9.0.120 which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | tomcat | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:9 | tomcat | 1:9.0.120-2.el9_8 | ALSA-2026:68660 |
| AlmaLinux:8 | tomcat-admin-webapps | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:9 | tomcat-admin-webapps | 1:9.0.120-2.el9_8 | ALSA-2026:68660 |
| AlmaLinux:8 | tomcat-docs-webapp | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:9 | tomcat-docs-webapp | 1:9.0.120-2.el9_8 | ALSA-2026:68660 |
| AlmaLinux:8 | tomcat-el-3.0-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:9 | tomcat-el-3.0-api | 1:9.0.120-2.el9_8 | ALSA-2026:68660 |
| AlmaLinux:8 | tomcat-jsp-2.3-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:9 | tomcat-jsp-2.3-api | 1:9.0.120-2.el9_8 | ALSA-2026:68660 |
| AlmaLinux:8 | tomcat-lib | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:9 | tomcat-lib | 1:9.0.120-2.el9_8 | ALSA-2026:68660 |
| AlmaLinux:8 | tomcat-servlet-4.0-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:9 | tomcat-servlet-4.0-api | 1:9.0.120-2.el9_8 | ALSA-2026:68660 |
| AlmaLinux:8 | tomcat-webapps | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:9 | tomcat-webapps | 1:9.0.120-2.el9_8 | ALSA-2026:68660 |
| AlmaLinux:10 | tomcat9 | 1:9.0.120-1.el10_2.alma.1 | ALSA-2026:68651 |
| AlmaLinux:10 | tomcat9-admin-webapps | 1:9.0.120-1.el10_2.alma.1 | ALSA-2026:68651 |
| AlmaLinux:10 | tomcat9-docs-webapp | 1:9.0.120-1.el10_2.alma.1 | ALSA-2026:68651 |
| AlmaLinux:10 | tomcat9-el-3.0-api | 1:9.0.120-1.el10_2.alma.1 | ALSA-2026:68651 |
| AlmaLinux:10 | tomcat9-jsp-2.3-api | 1:9.0.120-1.el10_2.alma.1 | ALSA-2026:68651 |
| AlmaLinux:10 | tomcat9-lib | 1:9.0.120-1.el10_2.alma.1 | ALSA-2026:68651 |
| AlmaLinux:10 | tomcat9-servlet-4.0-api | 1:9.0.120-1.el10_2.alma.1 | ALSA-2026:68651 |
| AlmaLinux:10 | tomcat9-webapps | 1:9.0.120-1.el10_2.alma.1 | ALSA-2026:68651 |
| Debian:12 | tomcat10 | no fix listed | DEBIAN-CVE-2026-59084 |
| Debian:13 | tomcat10 | no fix listed | DEBIAN-CVE-2026-59084 |
| Debian:14 | tomcat10 | 10.1.60-1 | DEBIAN-CVE-2026-59084 |
| Debian:13 | tomcat11 | no fix listed | DEBIAN-CVE-2026-59084 |
| Debian:14 | tomcat11 | 11.0.24-1 | DEBIAN-CVE-2026-59084 |
| Debian:12 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-59084 |
| Debian:13 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-59084 |
| Debian:14 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-59084 |
| Rocky Linux:8 | tomcat | 1:9.0.120-1.el8_10 | RLSA-2026:68677 |
| Rocky Linux:9 | tomcat | 1:9.0.120-2.el9_8 | RLSA-2026:68660 |
| Rocky Linux:10 | tomcat9 | 1:9.0.120-1.el10_2 | RLSA-2026:68651 |
| Ubuntu:24.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2026-59084 |
| Ubuntu:26.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2026-59084 |
| Ubuntu:26.10 | tomcat10 | no fix listed | UBUNTU-CVE-2026-59084 |
| Ubuntu:26.04:LTS | tomcat11 | no fix listed | UBUNTU-CVE-2026-59084 |
| Ubuntu:26.10 | tomcat11 | no fix listed | UBUNTU-CVE-2026-59084 |
| Ubuntu:24.04:LTS | tomcat9 | no fix listed | UBUNTU-CVE-2026-59084 |
| Ubuntu:26.04:LTS | tomcat9 | no fix listed | UBUNTU-CVE-2026-59084 |
| Ubuntu:26.10 | tomcat9 | no fix listed | UBUNTU-CVE-2026-59084 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 11.0.0-M1 – through 11.0.2310.1.0-M1 – through 10.1.569.0.13 – through 9.0.1198.5.38 – through 8.5.1007.0.100 – through 7.0.109 |
Weakness: CWE-1059 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N