Vulnerability · Published Jun 30, 2026 · Assigned by mitre
CVE-2026-58374
Medium 6.5
In plain English
A medium-severity security flaw in hostapd from w1.fi. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In hostapd before 2.12, a missing bounds check in AP-mode Wi-Fi 7 (IEEE 802.11be) Multi-Link Operation (MLO) association request processing allows an unauthenticated attacker within wireless range to send a crafted management frame containing a malformed Multi-Link Element or Per-STA Profile subelement. In hostapd_process_ml_assoc_req() in src/ap/ieee802_11_eht.c, the received link_id field can be parsed as value 15, but the corresponding links[] storage only has valid entries for lower link IDs (0 through 14). This causes an out-of-bounds write / small memory corruption during association processing before the 4-way handshake. The attack does not require network credentials, prior authentication, or user interaction. The confirmed practical impact is denial of service through hostapd process termination. This affects hostapd v2.11 and newer development snapshots before v2.12 when built with CONFIG_IEEE80211BE enabled. The issue is fixed in hostapd v2.12 and the upstream 2026-1 fixes.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | hostapd | 2.11-3.el10_2 | ALSA-2026:85276 |
| AlmaLinux:9 | hostapd | 2.11-3.el9_8 | ALSA-2026:85277 |
| Debian:12 | wpa | no fix listed | DEBIAN-CVE-2026-58374 |
| Debian:13 | wpa | no fix listed | DEBIAN-CVE-2026-58374 |
| Debian:14 | wpa | no fix listed | DEBIAN-CVE-2026-58374 |
| Rocky Linux:10 | hostapd | 0:2.11-3.el10_2 | RLSA-2026:85276 |
| Rocky Linux:9 | hostapd | 0:2.11-3.el9_8 | RLSA-2026:85277 |
| Ubuntu:22.04:LTS | wpa | no fix listed | UBUNTU-CVE-2026-58374 |
| Ubuntu:24.04:LTS | wpa | no fix listed | UBUNTU-CVE-2026-58374 |
| Ubuntu:25.10 | wpa | no fix listed | UBUNTU-CVE-2026-58374 |
| Ubuntu:26.04:LTS | wpa | no fix listed | UBUNTU-CVE-2026-58374 |
Affected products (as reported)
Weakness: CWE-193 · Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- hostap security advisory 2026-1: Missing multi-link parsing validation in wpa_supplicant and hostapd vendor-advisory
- hostap security advisory 2026-1 patch directory vendor-advisory, patch
- Fix commit 46dd5a4 - missing link ID bounds check patch
- Fix commit aa9d345 - BSS bounds check for link_id patch
- https://www.openwall.com/lists/oss-security/2026/06/30/1