Vulnerability · Published Jul 29, 2026 · Assigned by apache

CVE-2026-58162Apache Traffic Server: Certifier plugin trusts client SNI when generating certificates

Critical 10.0

In plain English

A critical-severity improper certificate validation in Apache Traffic Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities).

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)0.4%top 70.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The Apache Traffic Server certifier plugin generates certificates based on attacker-controlled client SNI. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12trafficserverno fix listedDEBIAN-CVE-2026-58162
Ubuntu:24.04:LTStrafficserverno fix listedUBUNTU-CVE-2026-58162

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Traffic Server 8.0.0 – through 8.1.119.0.0 – through 9.2.1410.0.0 – through 10.1.3

Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:H

References