Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M

CVE-2026-57455Vim: Stack out-of-bounds write in `spell_soundfold_sofo()` via an over-length `soundfold()` argument

Medium 4.0

In plain English

A medium-severity out-of-bounds write in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 2% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)4.0Medium
Exploit odds (30 days)0.1%top 98.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. Prior to 9.2.0698, the single-byte branch of spell_soundfold_sofo() in src/spell.c translates a word through a spell file's SOFO (sound-folding) byte map into a caller-owned result buffer. Its copy loop advances the output index ri with no upper bound and terminates only on the input NUL, writing one byte per input byte into the MAXWLEN-element stack buffer the caller provides. A word longer than MAXWLEN, passed to soundfold() (or reached via sound-based spell suggestion) while a SOFO-based spell language is active, therefore writes past the end of that buffer. This is a stack out-of-bounds write that corrupts the call frame and crashes the editor. This vulnerability is fixed in 9.2.0698.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10vim-X112:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:8vim-X112:8.0.1763-31.el8_10ALSA-2026:48703
AlmaLinux:9vim-X112:8.2.2637-26.el9_8.13ALSA-2026:47982
AlmaLinux:10vim-common2:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:8vim-common2:8.0.1763-31.el8_10ALSA-2026:48703
AlmaLinux:9vim-common2:8.2.2637-26.el9_8.13ALSA-2026:47982
AlmaLinux:10vim-data2:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:10vim-enhanced2:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:8vim-enhanced2:8.0.1763-31.el8_10ALSA-2026:48703
AlmaLinux:9vim-enhanced2:8.2.2637-26.el9_8.13ALSA-2026:47982
AlmaLinux:10vim-filesystem2:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:8vim-filesystem2:8.0.1763-31.el8_10ALSA-2026:48703
AlmaLinux:9vim-filesystem2:8.2.2637-26.el9_8.13ALSA-2026:47982
AlmaLinux:10vim-minimal2:9.1.083-9.el10_2.12ALSA-2026:48650
AlmaLinux:8vim-minimal2:8.0.1763-31.el8_10ALSA-2026:48703
AlmaLinux:9vim-minimal2:8.2.2637-26.el9_8.13ALSA-2026:47982
AlmaLinux:10xxd2:9.1.083-9.el10_2.12ALSA-2026:48650
Alpine:v3.23vim9.2.0854-r0ALPINE-CVE-2026-57455
Alpine:v3.24vim9.2.0699-r0ALPINE-CVE-2026-57455
Debian:12vimno fix listedDEBIAN-CVE-2026-57455
Debian:13vim2:9.1.1230-2+deb13u1DEBIAN-CVE-2026-57455
Debian:14vim2:9.2.0782-1DEBIAN-CVE-2026-57455
Rocky Linux:10vim2:9.1.083-9.el10_2.12RLSA-2026:48650
Rocky Linux:8vim2:8.0.1763-31.el8_10RLSA-2026:48703
Rocky Linux:9vim2:8.2.2637-26.el9_8.13RLSA-2026:47982
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.33USN-8500-1
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.33UBUNTU-CVE-2026-57455
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.17USN-8500-1
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.17UBUNTU-CVE-2026-57455
Ubuntu:25.10vim2:9.1.0967-1ubuntu6.8UBUNTU-CVE-2026-57455
Ubuntu:25.10vim2:9.1.0967-1ubuntu6.8USN-8500-1
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.6USN-8500-1
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.6UBUNTU-CVE-2026-57455

Affected products (as reported)

VendorProductVersions
vim vim < 9.2.0698

Weakness: CWE-787 · Vector: CVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

References