Vulnerability · Published Oct 27, 2026 · Assigned by GitHub_M

CVE-2026-57191Asterisk: Stack buffer overflow in MWI NOTIFY Message-Account parsing

High 8.2

In plain English

A high-severity buffer overflow in asterisk from asterisk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.6%top 51.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an unbounded `sscanf` in `res_pjsip_pubsub` when parsing the `MWI NOTIFY` `Message-Account` field may allow an unauthenticated attacker to send a carefully crafted packet that causes a stack buffer overflow and corrupts the underlying transport, permanently disabling all SIP functionality. An Asterisk restart is required to restore full operation. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14asterisk1:22.10.1+dfsg+~cs6.17.60671434-1DEBIAN-CVE-2026-57191
Ubuntu:22.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57191
Ubuntu:24.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57191
Ubuntu:26.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57191
Ubuntu:26.10asteriskno fix listedUBUNTU-CVE-2026-57191

Affected products (as reported)

VendorProductVersions
asterisk asterisk < 20.20.1>= 21.0.0-pre1, < 21.12.3>= 22.0.0-pre1, < 22.10.1>= 23.0.0-pre1, < 23.4.1
asterisk certified-asterisk < 20.7-cert11>= 22.8-cert1-pre1, < 22.8-cert3

Weakness: CWE-120, CWE-787 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References