Vulnerability · Published Jul 28, 2026 · Assigned by GitHub_M

CVE-2026-56822Netty: TOCTOU in OcspServerCertificateValidator

High 7.4

In plain English

A high-severity security flaw in netty from netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)0.2%top 93.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the OcspServerCertificateValidator forwards the SslHandshakeCompletionEvent before the asynchronous OCSP validation completes. This allows the client's downstream handlers to send sensitive application data (e.g., HTTP requests) to a revoked server before the channel is closed by the OCSP check. n io.netty.handler.ssl.ocsp.OcspServerCertificateValidator#userEventTriggered, when an SslHandshakeCompletionEvent is received, the validator immediately calls ctx.fireUserEventTriggered(evt). It then initiates an asynchronous OCSP query using OcspClient.query. Because the handshake completion event is forwarded immediately, downstream handlers in the client's pipeline are notified that the TLS handshake is successful. They may then begin reading and processing incoming application data or sending outgoing data. If the OCSP response later indicates the server's certificate is REVOKED, the validator closes the channel, but by this time, the client may have already leaked sensitive data to a revoked server or processed malicious responses from it. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12nettyno fix listedDEBIAN-CVE-2026-56822
Debian:13nettyno fix listedDEBIAN-CVE-2026-56822
Debian:14nettyno fix listedDEBIAN-CVE-2026-56822
Mavenio.netty:netty-handler-ssl-ocsp4.2.16.FinalGHSA-wc96-39fc-566f
Mavenio.netty:netty-handler-ssl-ocsp4.1.136.FinalGHSA-wc96-39fc-566f
Ubuntu:26.10nettyno fix listedUBUNTU-CVE-2026-56822

Affected products (as reported)

VendorProductVersions
netty netty >= 4.2.0.Final, < 4.2.16.Final< 4.1.136.Final

Weakness: CWE-367 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

References