Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M
CVE-2026-55602http-proxy-middleware `router` host+path substring matching allows Host-header-driven backend routing bypass
Medium 6.9
In plain English
A medium-severity improper input validation in http-proxy-middleware from chimurai. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
http-proxy-middleware is node.js http-proxy middleware. From 0.16.0 until 2.0.10, 3.0.6, and 4.1.0, http-proxy-middleware documents router proxy-table entries as host, path, or host+path selectors, but the host+path implementation uses unanchored substring matching on attacker-controlled request metadata. As a result, a crafted Host header that is only a superstring match for a configured host+path key can still route a request to an unintended backend. This vulnerability is fixed in 2.0.10, 3.0.6, and 4.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | http-proxy-middleware | 3.0.6 | GHSA-64mm-vxmg-q3vj |
| npm | http-proxy-middleware | 4.1.0 | GHSA-64mm-vxmg-q3vj |
| npm | http-proxy-middleware | 2.0.10 | GHSA-64mm-vxmg-q3vj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| chimurai | http-proxy-middleware | >= 4.0.0, < 4.1.0>= 3.0.0, < 3.0.6>= 0.16.0, < 2.0.10 |
Weakness: CWE-20, CWE-187 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N