Vulnerability · Published Oct 14, 2026 · Assigned by GitHub_M
CVE-2026-55573e107: Unsafe deserialization in install.php allows unauthenticated RCE via POP chain
Critical 9.8
In plain English
A critical-severity unsafe deserialization in e107 from e107inc. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities).
Official description
e107 is a content management system (CMS). Prior to 2.3.7, install.php decodes the attacker-controlled previous_steps POST parameter and passes it to unserialize() at file scope and again in the e_install constructor without restricting allowed classes. The installer remains accessible after a normal installation, and a crafted object graph using the bundled GuzzleHttp\Psr7\PumpStream class can flow through paths.hash into site_path, where string coercion invokes an attacker-controlled callable. An unauthenticated attacker who can reach install.php can therefore execute arbitrary PHP functions with the web server process's privileges, leading to full server compromise. This issue is fixed in version 2.3.7.
Affected products (as reported)
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/e107inc/e107/security/advisories/GHSA-c8h6-wpj3-4cr8 x_refsource_CONFIRM
- https://github.com/e107inc/e107/commit/5d6d649e8cf01854d6024d07997c2449fdd75f24 x_refsource_MISC
- https://github.com/e107inc/e107/commit/6c404295213952aedb9b3689be19dd4c7ba550b0 x_refsource_MISC
- https://github.com/e107inc/e107/releases/tag/v2.3.7 x_refsource_MISC