Vulnerability · Published Aug 26, 2026 · Assigned by GitHub_M
CVE-2026-55182LibreNMS: Remote Code Execution by Signal Alert Transportation Module
High 8.6
In plain English
A high-severity command injection in librenms from librenms. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
LibreNMS is a network monitoring system. In versions from 21.6.0 up to 26.5.0, the Signal alert transport is vulnerable to command injection because the signal-cli path and the Recipient field of an alert transport entry are insufficiently escaped before being passed to an exec call. An authenticated administrator can craft a transport entry whose Recipient contains shell metacharacters and whose path points to the bundled composer_wrapper.php script, which itself passes attacker-controlled input to further unsafe exec calls. By chaining these calls, the administrator can execute arbitrary operating-system commands on the LibreNMS host. This issue is fixed in version 26.5.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | librenms/librenms | 26.5.0 | GHSA-c9fv-cgmm-2wg7 |
Affected products (as reported)
Weakness: CWE-77 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/librenms/librenms/security/advisories/GHSA-c9fv-cgmm-2wg7 x_refsource_CONFIRM
- https://github.com/librenms/librenms/commit/868e3b966a x_refsource_MISC
- https://github.com/librenms/librenms/releases/tag/26.5.0 x_refsource_MISC