Vulnerability · Published Aug 21, 2026 · Assigned by GitHub_M
CVE-2026-54789mod_auth_openidc has out-of-bounds read and write in state cookie parsing
High 7.5
In plain English
A high-severity out-of-bounds read in mod_auth_openidc from OpenIDC. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
mod_auth_openidc is an OpenID Certified authentication and authorization module for the Apache 2.x HTTP server that implements the OpenID Connect Relying Party functionality. Prior to 2.4.19.4, an out-of-bounds read and a one-byte out-of-bounds write exist in the state-cookie parser of `mod_auth_openidc`. The issue is fixed in version 2.4.19.4 by stopping the scan at the string terminator so a value-less token is rejected. No in-product workarounds are available. As a stop-gap, an upstream reverse proxy or WAF that rejects or normalizes malformed `Cookie` headers (tokens lacking `=`) can reduce exposure, but upgrading is the recommended remediation.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | cjose | 0.6.1-5.module_el8.10.0+4297+63ae3533 | ALSA-2026:77369 |
| AlmaLinux:8 | cjose-devel | 0.6.1-5.module_el8.10.0+4297+63ae3533 | ALSA-2026:77369 |
| AlmaLinux:10 | mod_auth_openidc | 2.4.16.11-1.el10_2.1 | ALSA-2026:75581 |
| AlmaLinux:8 | mod_auth_openidc | 2.4.9.4-9.module_el8.10.0+4297+63ae3533 | ALSA-2026:77369 |
| AlmaLinux:9 | mod_auth_openidc | 2.4.16.11-1.el9_8.1 | ALSA-2026:79177 |
| Debian:12 | libapache2-mod-auth-openidc | 2.4.12.3-2+deb12u5 | DEBIAN-CVE-2026-54789 |
| Debian:13 | libapache2-mod-auth-openidc | 2.4.17-1+deb13u1 | DEBIAN-CVE-2026-54789 |
| Debian:14 | libapache2-mod-auth-openidc | 2.4.19.4-1 | DEBIAN-CVE-2026-54789 |
| Rocky Linux:8 | cjose | 0:0.6.1-5.module+el8.10.0+40373+8a3f15d2 | RLSA-2026:77369 |
| Rocky Linux:10 | mod_auth_openidc | 0:2.4.16.11-1.el10_2.1 | RLSA-2026:75581 |
| Rocky Linux:8 | mod_auth_openidc | 0:2.4.9.4-9.module+el8.10.0+40373+8a3f15d2 | RLSA-2026:77369 |
| Rocky Linux:9 | mod_auth_openidc | 0:2.4.16.11-1.el9_8.1 | RLSA-2026:79177 |
| Ubuntu:22.04:LTS | libapache2-mod-auth-openidc | no fix listed | UBUNTU-CVE-2026-54789 |
| Ubuntu:24.04:LTS | libapache2-mod-auth-openidc | no fix listed | UBUNTU-CVE-2026-54789 |
| Ubuntu:26.04:LTS | libapache2-mod-auth-openidc | no fix listed | UBUNTU-CVE-2026-54789 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenIDC | mod_auth_openidc | < 2.4.19.4 |
Weakness: CWE-125, CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H