Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M
CVE-2026-54679jq: potential integer overflow in jvp_string_append
Medium 6.9
In plain English
A medium-severity integer overflow in jq from jqlang. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.1%top 96.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
jq is a command-line JSON processor. Prior to 1.8.2, on 32bit system, jvp_string_append has a chance of integer/multiple overflowing and then causing a massive buffer overrun. This vulnerability is fixed in 1.8.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.22 | jq | 1.8.2-r0 | ALPINE-CVE-2026-54679 |
| Alpine:v3.23 | jq | 1.8.2-r0 | ALPINE-CVE-2026-54679 |
| Alpine:v3.24 | jq | 1.8.2-r0 | ALPINE-CVE-2026-54679 |
| Debian:12 | jq | 1.6-2.1+deb12u2 | DEBIAN-CVE-2026-54679 |
| Debian:13 | jq | 1.7.1-6+deb13u3 | DEBIAN-CVE-2026-54679 |
| Debian:14 | jq | 1.8.2-1 | DEBIAN-CVE-2026-54679 |
| Ubuntu:22.04:LTS | jq | no fix listed | UBUNTU-CVE-2026-54679 |
| Ubuntu:24.04:LTS | jq | no fix listed | UBUNTU-CVE-2026-54679 |
| Ubuntu:25.10 | jq | no fix listed | UBUNTU-CVE-2026-54679 |
| Ubuntu:26.04:LTS | jq | no fix listed | UBUNTU-CVE-2026-54679 |
| Ubuntu:26.10 | jq | no fix listed | UBUNTU-CVE-2026-54679 |
Affected products (as reported)
Weakness: CWE-190 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/jqlang/jq/security/advisories/GHSA-29gj-222p-j7vx x_refsource_CONFIRM