Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M
CVE-2026-54307n8n: Credential Exfiltration via Permission Bypass
High 8.5
In plain English
A high-severity incorrect authorization in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.2, a member-level user with editor access to a shared workflow could reference credentials they do not own via specific public API endpoints. Credential ownership checks were only enforced partially leading to cross-user credential access. This issue affects instances where workflow sharing is enabled and at least one workflow has been shared with a member-level user as an Editor. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | n8n | 1.123.55 | GHSA-pmqw-72cg-wx85 |
| npm | n8n | 2.26.2 | GHSA-pmqw-72cg-wx85 |
| npm | n8n | 2.25.7 | GHSA-pmqw-72cg-wx85 |
Affected products (as reported)
Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:L
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-pmqw-72cg-wx85 x_refsource_CONFIRM