Vulnerability · Published Jul 1, 2026 · Assigned by GitHub_M
CVE-2026-54263Wagtail: Reflected XSS in dynamic image URL generator view
High 7.3
In plain English
A high-severity cross-site scripting in wagtail from wagtail. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Wagtail is an open source content management system built on Django. In versions prior to 7.0.8, 7.3.3 and 7.4.2, reflected cross-site scripting (XSS) vulnerability exists on the dynamic image URL generator view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could craft a URL that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is present for all sites, even if they do not enable the dynamic image serve view. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been fixed in versions 7.0.8, 7.3.3, and 7.4.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | wagtail | 7.3.3 | GHSA-23m2-mghx-vqmf |
| PyPI | wagtail | 7.4.2 | GHSA-23m2-mghx-vqmf |
| PyPI | wagtail | 7.3.3, 7.4.2 | PYSEC-2026-616 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
References
- https://github.com/wagtail/wagtail/security/advisories/GHSA-23m2-mghx-vqmf x_refsource_CONFIRM