Vulnerability · Published Jul 1, 2026 · Assigned by GitHub_M
CVE-2026-54259Wagtail: Improper restriction handling on Documents and Images chosen endpoints
Medium 4.3
In plain English
A medium-severity security flaw in wagtail from wagtail. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Wagtail is an open source content management system built on Django. In versions prior to 7.0.8, 7.3.3 and 7.4.2, the Documents and Images chooser's chosen endpoint incorrectly listed items for which the user has not been granted choose permission. A user with access to the Wagtail admin could see the filename and name and URLs of documents and images in those collections. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been fixed in versions 7.0.8, 7.3.3, and 7.4.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | wagtail | 7.0.8 | GHSA-h54r-xq46-qwqm |
| PyPI | wagtail | 7.3.3 | GHSA-h54r-xq46-qwqm |
| PyPI | wagtail | 7.4.2 | GHSA-h54r-xq46-qwqm |
| PyPI | wagtail | 7.0.8, 7.3.3, 7.4.2 | PYSEC-2026-612 |
Affected products (as reported)
Weakness: CWE-280 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
References
- https://github.com/wagtail/wagtail/security/advisories/GHSA-h54r-xq46-qwqm x_refsource_CONFIRM