Vulnerability · Published Apr 10, 2026 · Assigned by canonical

CVE-2026-5412Juju CloudSpec API could leak senstive information

Critical 9.9

In plain English

A critical-severity security flaw in Juju from Canonical. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.9Critical
Exploit odds (30 days)0.4%top 61.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

In Juju versions prior to 2.9.57 and 3.6.21, an authorization issue exists in the Controller facade. An authenticated user can call the CloudSpec API method to extract the cloud credentials used to bootstrap the controller. This allows a low-privileged user to access sensitive credentials. This issue is resolved in Juju versions 2.9.57 and 3.6.21.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/juju/juju0.0.0-20260408003526-d395054dc2c3GO-2026-5692
Gogithub.com/juju/juju0.0.0-20260408003526-d395054dc2c3GHSA-w5fq-8965-c969

Affected products (as reported)

VendorProductVersions
Canonical Juju 2.9.0 – before 2.9.573.6.0 – before 3.6.21

Weakness: CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References