Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M
CVE-2026-53655node-tar applies PAX size override to intermediary GNU long-name/long-link headers, causing tar parser interpretation differential (file smuggling)
Medium 6.9
In plain English
A medium-severity security flaw in node-tar from isaacs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
node-tar is a full-featured Tar for Node.js. Prior to 7.5.16, tar (node-tar) applies a PAX extended header's size= record (and other PAX overrides) to the next header entry of any type, including intermediary metadata headers such as a GNU long-name (L) or long-link (K) entry. Per POSIX pax, a PAX extended header (x) describes the next file entry, not the intermediary extension headers that may sit between the x header and the file it annotates. Because node-tar lets the PAX size override the byte length of an intervening L/K/x header, an attacker can desynchronize node-tar's stream cursor relative to every other mainstream tar implementation (GNU tar, libarchive/bsdtar, Python tarfile, and the now-fixed tar-rs / astral-tokio-tar). The result is a tar parser interpretation differential (CWE-436): a single crafted archive yields a different set of members under node-tar than under the reference tar tools. An attacker can use this to hide a member from one parser while it is visible to another, which defeats security tooling whose scanner and extractor disagree on archive contents (e.g. a malware/secret scanner that lists entries with one library while a downstream step extracts with another) This vulnerability is fixed in 7.5.16.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-tar | no fix listed | DEBIAN-CVE-2026-53655 |
| Debian:13 | node-tar | no fix listed | DEBIAN-CVE-2026-53655 |
| Debian:14 | node-tar | 7.5.16+~4.0.1-2 | DEBIAN-CVE-2026-53655 |
| Ubuntu:22.04:LTS | node-tar | no fix listed | UBUNTU-CVE-2026-53655 |
| Ubuntu:24.04:LTS | node-tar | no fix listed | UBUNTU-CVE-2026-53655 |
| Ubuntu:25.10 | node-tar | no fix listed | UBUNTU-CVE-2026-53655 |
| Ubuntu:26.04:LTS | node-tar | no fix listed | UBUNTU-CVE-2026-53655 |
| Ubuntu:26.10 | node-tar | no fix listed | UBUNTU-CVE-2026-53655 |
| npm | tar | 7.5.16 | GHSA-vmf3-w455-68vh |
Affected products (as reported)
Weakness: CWE-436 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/isaacs/node-tar/security/advisories/GHSA-vmf3-w455-68vh x_refsource_CONFIRM