Vulnerability · Published Sep 14, 2026 · Assigned by GitHub_M

CVE-2026-53495containerd CRI ExecSync Goroutine Leak Leading to Node-Level Denial of Service

Medium 6.8

In plain English

A medium-severity uncontrolled resource consumption in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.8Medium
Exploit odds (30 days)0.2%top 94.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

containerd is an open-source container runtime. Prior to 1.7.35, 2.0.12, 2.2.8, and 2.3.5, containerd on Linux with the CRI plugin enabled can indefinitely block the drainExecSyncIO goroutine in internal/cri/server/container_execsync.go when CRI ExecSync is used by exec probes or lifecycle hooks that launch long-lived background child processes retaining standard input and output pipes. The input and output drain phase has no default timeout and did not stop when the request context was canceled, so repeated ExecSync invocations can accumulate blocked goroutines and host memory. The resulting resource exhaustion can cause the OOM killer to terminate containerd, leaving the container runtime unavailable until restart. Deployments not using containerd's CRI implementation and containers not running on Linux are not affected. This issue is fixed in versions 1.7.35, 2.0.12, 2.2.8, and 2.3.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24containerd2.3.5-r0ALPINE-CVE-2026-53495
Debian:12containerdno fix listedDEBIAN-CVE-2026-53495
Debian:13containerdno fix listedDEBIAN-CVE-2026-53495
Debian:14containerd2.1.9+ds1-4DEBIAN-CVE-2026-53495
Gogithub.com/containerd/containerd1.7.35GO-2026-6444
Gogithub.com/containerd/containerd1.7.35GHSA-7jxh-36q5-gcqv
Gogithub.com/containerd/containerd/v22.0.12GHSA-7jxh-36q5-gcqv
Gogithub.com/containerd/containerd/v22.2.8GHSA-7jxh-36q5-gcqv
Gogithub.com/containerd/containerd/v22.3.5GHSA-7jxh-36q5-gcqv
Gogithub.com/containerd/containerd/v22.0.12, 2.2.8, 2.3.5GO-2026-6444
Ubuntu:22.04:LTScontainerdno fix listedUBUNTU-CVE-2026-53495
Ubuntu:26.10containerdno fix listedUBUNTU-CVE-2026-53495
Ubuntu:24.04:LTScontainerd-appno fix listedUBUNTU-CVE-2026-53495
Ubuntu:26.04:LTScontainerd-appno fix listedUBUNTU-CVE-2026-53495
Ubuntu:26.10containerd-appno fix listedUBUNTU-CVE-2026-53495
Ubuntu:26.04:LTScontainerd-stableno fix listedUBUNTU-CVE-2026-53495
Ubuntu:26.10containerd-stableno fix listedUBUNTU-CVE-2026-53495

Affected products (as reported)

VendorProductVersions
containerd containerd < 1.7.35>= 2.0.0, < 2.0.12>= 2.2.0, < 2.2.8>= 2.3.0, < 2.3.5

Weakness: CWE-400 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References