Vulnerability · Published Jun 29, 2026 · Assigned by apache

CVE-2026-53434Apache Tomcat: Invalid CRL configuration doesn't trigger failure for FFM Connector

Critical 9.1

In plain English

A critical-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 48% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.6%top 51.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Detection of Error Condition Without Action vulnerability in Apache Tomcat when configuring CRLs for a FFM based connector. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M7 through 10.1.55, from 9.0.83 through 9.0.118. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-admin-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-admin-webapps1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-docs-webapp1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-docs-webapp1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-el-3.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-el-3.0-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-lib1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-lib1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-webapps1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat91:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-admin-webapps1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-docs-webapp1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-el-3.0-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-lib1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-webapps1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
Debian:12tomcat10no fix listedDEBIAN-CVE-2026-53434
Debian:13tomcat10no fix listedDEBIAN-CVE-2026-53434
Debian:14tomcat1010.1.60-1DEBIAN-CVE-2026-53434
Debian:13tomcat11no fix listedDEBIAN-CVE-2026-53434
Debian:14tomcat1111.0.24-1DEBIAN-CVE-2026-53434
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-53434
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-53434
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-53434
Mavenorg.apache.tomcat:tomcat-util9.0.119GHSA-4x29-79gh-6v8q
Mavenorg.apache.tomcat:tomcat-util11.0.23GHSA-4x29-79gh-6v8q
Mavenorg.apache.tomcat:tomcat-util10.1.56GHSA-4x29-79gh-6v8q
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-53434
Ubuntu:25.10tomcat10no fix listedUBUNTU-CVE-2026-53434
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-53434
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2026-53434
Ubuntu:25.10tomcat11no fix listedUBUNTU-CVE-2026-53434
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-53434
Ubuntu:26.10tomcat11no fix listedUBUNTU-CVE-2026-53434
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-53434
Ubuntu:25.10tomcat9no fix listedUBUNTU-CVE-2026-53434
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-53434
Ubuntu:26.10tomcat9no fix listedUBUNTU-CVE-2026-53434

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.2210.1.0-M7 – through 10.1.559.0.83 – through 9.0.118

Weakness: CWE-390 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

References