Vulnerability · Published Jun 11, 2026 · Assigned by GitHub_M

CVE-2026-52860Vim: Arbitrary Code Execution via Python Omni-Completion

High 8.0

In plain English

A high-severity code injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)0.2%top 86.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. Prior to version 9.2.0597, Vim's Python omni-completion executes reconstructed function and class definitions from the current buffer with exec() as part of populating the completion dictionary. Python evaluates function default values, parameter annotations, and class base expressions at definition time, so a hostile buffer can execute attacker-controlled Python expressions during omni-completion. The existing g:pythoncomplete_allow_import mitigation (GHSA-52mc-rq6p-rc7c) does not cover this path, because the attacker-controlled code is not a harvested import/from statement. This issue has been patched in version 9.2.0597.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23vim9.2.0602-r0ALPINE-CVE-2026-52860
Alpine:v3.24vim9.2.0602-r0ALPINE-CVE-2026-52860
Debian:12vimno fix listedDEBIAN-CVE-2026-52860
Debian:13vim2:9.1.1230-2+deb13u1DEBIAN-CVE-2026-52860
Debian:14vim2:9.2.0782-1DEBIAN-CVE-2026-52860
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.32UBUNTU-CVE-2026-52860
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.16UBUNTU-CVE-2026-52860
Ubuntu:25.10vim2:9.1.0967-1ubuntu6.7UBUNTU-CVE-2026-52860
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.5UBUNTU-CVE-2026-52860

Affected products (as reported)

VendorProductVersions
vim vim < 9.2.0597

Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

References