Vulnerability · Published Jun 11, 2026 · Assigned by GitHub_M
CVE-2026-52858Vim: Arbitrary Code Execution via Python Omni-Completion
High 7.3
In plain English
A high-severity code injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Vim is an open source, command line text editor. Prior to version 9.2.0561, the Python omni-completion script in python3complete.vim for Vim with the +python3 interpreter enabled (and the legacy pythoncomplete.vim for builds with the +python interpreter) executes the import and from statements found in the current buffer through Python's import machinery. Because the buffer's working directory is on sys.path, opening a hostile .py file with a sibling Python package and invoking omni-completion runs that package's top-level code as the editing user. This issue has been patched in version 9.2.0561.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | vim-X11 | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:8 | vim-X11 | 2:8.0.1763-27.el8_10 | ALSA-2026:38510 |
| AlmaLinux:9 | vim-X11 | 2:8.2.2637-26.el9_8.10 | ALSA-2026:38511 |
| AlmaLinux:10 | vim-common | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:8 | vim-common | 2:8.0.1763-27.el8_10 | ALSA-2026:38510 |
| AlmaLinux:9 | vim-common | 2:8.2.2637-26.el9_8.10 | ALSA-2026:38511 |
| AlmaLinux:10 | vim-data | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:10 | vim-enhanced | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:8 | vim-enhanced | 2:8.0.1763-27.el8_10 | ALSA-2026:38510 |
| AlmaLinux:9 | vim-enhanced | 2:8.2.2637-26.el9_8.10 | ALSA-2026:38511 |
| AlmaLinux:10 | vim-filesystem | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:8 | vim-filesystem | 2:8.0.1763-27.el8_10 | ALSA-2026:38510 |
| AlmaLinux:9 | vim-filesystem | 2:8.2.2637-26.el9_8.10 | ALSA-2026:38511 |
| AlmaLinux:10 | vim-minimal | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| AlmaLinux:8 | vim-minimal | 2:8.0.1763-27.el8_10 | ALSA-2026:38510 |
| AlmaLinux:9 | vim-minimal | 2:8.2.2637-26.el9_8.10 | ALSA-2026:38511 |
| AlmaLinux:10 | xxd | 2:9.1.083-9.el10_2.7 | ALSA-2026:38509 |
| Alpine:v3.23 | vim | 9.2.0498-r0 | ALPINE-CVE-2026-52858 |
| Alpine:v3.24 | vim | 9.2.0498-r0 | ALPINE-CVE-2026-52858 |
| Debian:12 | vim | no fix listed | DEBIAN-CVE-2026-52858 |
| Debian:13 | vim | 2:9.1.1230-2+deb13u1 | DEBIAN-CVE-2026-52858 |
| Debian:14 | vim | 2:9.2.0782-1 | DEBIAN-CVE-2026-52858 |
| Rocky Linux:10 | vim | 2:9.1.083-9.el10_2.7 | RLSA-2026:38509 |
| Rocky Linux:8 | vim | 2:8.0.1763-27.el8_10 | RLSA-2026:38510 |
| Rocky Linux:9 | vim | 2:8.2.2637-26.el9_8.10 | RLSA-2026:38511 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.32 | UBUNTU-CVE-2026-52858 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.16 | UBUNTU-CVE-2026-52858 |
| Ubuntu:25.10 | vim | 2:9.1.0967-1ubuntu6.7 | UBUNTU-CVE-2026-52858 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.5 | UBUNTU-CVE-2026-52858 |
Affected products (as reported)
Weakness: CWE-94, CWE-95, CWE-829 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/vim/vim/security/advisories/GHSA-52mc-rq6p-rc7c x_refsource_CONFIRM
- https://github.com/vim/vim/commit/4b850457e12e1a678dd209f2868154f7553cbf8d x_refsource_MISC
- https://github.com/vim/vim/releases/tag/v9.2.0561 x_refsource_MISC